
LabVIEW  Release Notes
Version 8.2

These release notes contain installation and uninstallation instructions for 
LabVIEW, system requirements for the LabVIEW software, and known 
issues with LabVIEW 8.2.

If you are upgrading from a previous version of LabVIEW, read the 
LabVIEW Upgrade Notes included with the upgrade package before you 
install LabVIEW 8.2. You must consider several issues before you convert 
VIs for use in LabVIEW 8.2.

Read the System Requirements section of this document before you install 
LabVIEW and then follow the instructions in the Installing LabVIEW 8.2 
section. After you install LabVIEW, read the Where to Go from Here 
section for information about getting started with and using LabVIEW.
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System Requirements
Table 1 describes the system requirements you need to run LabVIEW 8.2.

 
Table 1.  System Requirements for LabVIEW 8.2

Platform
Media and System 

Requirements Important Notes

All platforms LabVIEW requires a 
minimum of 256 MB 
of RAM, but National 
Instruments recommends 
512 MB of RAM.

LabVIEW requires a 
screen resolution of 
1,024 × 768 pixels.

When you deploy an 
application you build, the 
LabVIEW Run-Time 
Engine requires a minimum 
of 64 MB of RAM and 
a screen resolution of 
800 × 600 pixels for 
applications that require 
a screen, but National 
Instruments recommends 
256 MB of RAM and a 
screen resolution of 
1,024 × 768 pixels.

LabVIEW and the LabVIEW Help contain 
16-bit color graphics.

LabVIEW requires a minimum color palette 
setting of 256 colors, but National 
Instruments recommends 16-bit color or 
higher.

You must have Adobe Reader 5.0.5 or later to 
view PDF versions of all LabVIEW manuals. 
You must have Adobe Reader with Search 
and Accessibility 6.x or later to search 
the PDFs. (Mac OS) You must have Adobe 
Reader with Search and Accessibility 6.x or 
later to view and search the PDFs.

LabVIEW uses a directory for storing 
temporary files. National Instruments 
recommends that you have several megabytes 
of disk space available for this temporary 
directory. You can view or change the 
temporary directory by selecting Tools»
Options and selecting Paths from the 
Category list. If LabVIEW aborts 
unexpectedly, it can leave files in the 
temporary directory. Remove old files from 
this directory to free disk space. 
(Windows) The default temporary directory 
is the system temporary directory, such as 
C:\Documents and Settings\User\

Local Settings\Temp. 
(Mac OS) Mac OS X 10.3.9 uses the default 
temporary directory \tmp\501\
TemporaryItems, and Mac OS X 10.4.x 
uses \var\tmp\folders.501\
TemporaryItems, where 501 is a unique 
number for each login.
(Linux) The default temporary directory 
is /tmp.
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Windows 
2000/XP

LabVIEW requires a 
minimum of a Pentium III or 
greater or Celeron 866 MHz 
or equivalent processor, but 
National Instruments 
recommends a Pentium 4/M 
or equivalent processor. 
National Instruments 
recommends that you have at 
least 1.2 GB of disk space 
for the complete LabVIEW 
installation.

When you deploy an 
application you build, the 
LabVIEW Run-Time 
Engine requires a minimum 
of a Pentium 200 MHz or 
equivalent processor, but 
National Instruments 
recommends a Pentium III 
or greater or Celeron 
600 MHz or equivalent 
processor. The LabVIEW 
Run-Time Engine requires 
at least 80 MB of disk space, 
but National Instruments 
recommends 580 MB of 
disk space if you install the 
device drivers from the 
National Instruments Device 
Drivers CD. On Windows 
2000, the LabVIEW 
Run-Time Engine requires 
Windows 2000 Service 
Pack 3 or later.

LabVIEW does not support 
Windows NT/Me/98/95 or Windows XP x64. 

To use LabVIEW with Windows 2000, you 
must have Windows 2000 Service Pack 3 or 
later.

To use the LabVIEW Help, the Measurement 
& Automation Explorer (MAX) interactive 
help system, and the NI Example Finder, you 
must have Microsoft Internet Explorer 5.0 or 
later.

To view and control a front panel remotely 
using Internet Explorer, National Instruments 
recommends that you have Internet 
Explorer 5.5 Service Pack 2 or later.

To use Windows Explorer to display or 
modify the contents of .llb files, you must 
have Internet Explorer 5.5 Service Pack 1 or 
later.

You must have the .NET Framework 1.1 
Service Pack 1 or later to use .NET functions 
and applications.

Table 1.  System Requirements for LabVIEW 8.2 (Continued)

Platform
Media and System 

Requirements Important Notes
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Mac OS LabVIEW requires 
Mac OS X 10.3.9 or later.

LabVIEW requires a 
minimum of a G3 processor, 
but National Instruments 
recommends a G4 or greater 
processor. National 
Instruments recommends 
that you have at least 
500 MB of disk space for the 
minimum LabVIEW 
installation or 700 MB disk 
space for the complete 
LabVIEW installation.

National Instruments recommends that you 
use Firefox 1.0.2 or later or Safari 1.3.2 or 
later to view the LabVIEW Help.

LabVIEW 8.2 provides some support for 
Macintosh computers with Intel processors. 
Refer to the National Instruments Web site at 
ni.com/info and enter the info code 
macintel for more information about 
Macintosh support. 

Table 1.  System Requirements for LabVIEW 8.2 (Continued)

Platform
Media and System 

Requirements Important Notes

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=macintel
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Linux LabVIEW requires an 
X Window System server, 
such as OpenWindows, 
CDE, or X11R6.

National Instruments 
recommends that you have at 
least 430 MB of disk space 
for the minimum LabVIEW 
installation or 620 MB disk 
space for the complete 
LabVIEW installation.

LabVIEW runs on Linux for 
Intel x86 processors with 
kernel version 2.2.x, 2.4.x, 
or 2.6.x. LabVIEW requires 
a minimum of a Pentium III 
or Celeron 866 MHz or 
equivalent processor, but 
National Instruments 
recommends a Pentium 4/M 
or equivalent processor.

LabVIEW runs on Red Hat 
Enterprise Linux WS 3 
or later, MandrakeLinux/ 
Mandriva 10.0 or later, and 
SuSE Linux 9.1 or later. 
LabVIEW can run without 
hardware driver support on 
any other distributions that 
provide GNU C Library 
(glibc, also known 
as libc.so.6) 
version 2.2.4 or later.

LabVIEW does not require a specific 
graphical user interface (GUI) such as Motif 
or OpenLook because LabVIEW uses Xlib 
to create its own GUI.

National Instruments recommends that you 
use Firefox 1.0.2 or later or Mozilla 1.2 or 
later to view the LabVIEW Help.

LabVIEW requires GNU C Library 
version 2.2.4 or later. Most Linux vendors 
offer an updated glibc rpm for most Linux 
distributions on their Web sites so you do not 
have to upgrade the entire system.

Table 1.  System Requirements for LabVIEW 8.2 (Continued)

Platform
Media and System 

Requirements Important Notes
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Installing LabVIEW 8.2
Refer to the KnowledgeBase at ni.com if you encounter errors during 
installation.

Windows
Complete the following steps to install LabVIEW for Windows.

1. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with the installation program.

2. Log on as an administrator or as a user with administrator privileges.

3. Insert the LabVIEW 8.2 installation CD and follow the instructions 
that appear on the screen. The prompt directs you to install LabVIEW, 
then the directions on the screen help you activate your LabVIEW 
license. Refer to the Activating the LabVIEW License (Windows) 
section of this document for more information about activating 
LabVIEW.

4. After installation, enable any virus detection programs you disabled.

5. (Optional) Install LabVIEW add-ons. Refer to the Installing LabVIEW 
Add-Ons section of this document for more information.

6. (Optional) Install and configure National Instruments hardware. Refer 
to the Installing and Configuring Hardware section of this document 
for more information.

7. Refer to the Where to Go from Here section of this document for more 
information about getting started with and using LabVIEW.

To modify the current LabVIEW installation or to uninstall LabVIEW 8.2, 
select National Instruments Software in the Add/Remove Programs 
applet in the Control Panel. When you modify the installation, a list of 
National Instruments software appears. Select a product in the list to add or 
remove individual components or to uninstall the product. Select multiple 
products to remove by pressing the <Shift> or <Ctrl> key while you select 
them. Click the Uninstall button to remove all the products you selected.

Note If you have Windows XP Service Pack 2 installed, a Security Alert dialog box 
appears when you launch LabVIEW or the NI Example Finder for the first time. If you 
select the Keep blocking this program option, the LabVIEW VI Server, LabVIEW Web 
Server, and any server written in LabVIEW cannot accept incoming connections from a 
remote computer. Select the Unblock this program, despite the security risk option to 
configure your computer to launch LabVIEW without any changes in functionality. Refer 
to the National Instruments Web site at ni.com/info and enter the info code exzgbg for 
more information about correcting this problem.

http://digital.ni.com/express.nsf/express?openagent&code=exzgbg
http://digital.ni.com/public.nsf/MainPage?OpenForm&node=133020_US
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Mac OS
Complete the following steps to install LabVIEW for Mac OS.

1. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with the installation program.

2. Insert the LabVIEW 8.2 installation CD.

3. Run the appropriate installation program.

The following types of installations of LabVIEW 8.2 are available:

• Easy Install—Installs all LabVIEW 8.2 files, including 
LabVIEW, NI-488.2 drivers, and NI-VISA drivers. This is the 
default installation for LabVIEW.

• Custom Install—If you select this option, you select the files to 
install. To select a custom installation, click the Customize button 
on the Installation Type page. You must select the LabVIEW 8.2 
component to install the core set of LabVIEW files necessary for 
running LabVIEW 8.2.

4. Follow the instructions that appear on the screen.

5. After installation, enable any virus detection programs you disabled.

6. (Optional) Install LabVIEW add-ons. Refer to the Installing LabVIEW 
Add-Ons section of this document for more information.

7. (Optional) Install and configure National Instruments hardware. Refer 
to the Installing and Configuring Hardware section of this document 
for more information.

8. Refer to the Where to Go from Here section of this document for more 
information about getting started with and using LabVIEW.

You cannot install LabVIEW into a non-default location, but you can 
move the LabVIEW 8.2 directory after you install. If you move the 
LabVIEW 8.2 directory to a non-default location, LabVIEW does not 
uninstall and remove the directory unless you move the LabVIEW 8.2 
directory back to the default location.

To uninstall LabVIEW 8.2, run the Uninstall.sh shell script file on the 
installation CD from a Terminal shell. The script directs you to remove the 
files necessary to uninstall LabVIEW. If you want to keep any files you 
modified or added to the LabVIEW 8.2 directory, save those files in 
another location before uninstalling LabVIEW 8.2. 
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Linux
Complete the following steps to install LabVIEW for Linux.

1. Log into the system as root.

2. Insert the LabVIEW 8.2 installation CD. Use mount /mnt/cdrom to 
mount the CD. On some systems, the CD mounts automatically.

3. To change the current directory to the mounted CD, enter the following 
command:

cd /mnt/cdrom

4. To run the installation script, enter the following command:

sh ./INSTALL

5. (Optional) Install LabVIEW add-ons. Refer to the Installing LabVIEW 
Add-Ons section of this document for more information.

6. (Optional) Install and configure National Instruments hardware. Refer 
to the Installing and Configuring Hardware section of this document 
for more information.

7. Refer to the Where to Go from Here section of this document for more 
information about getting started with and using LabVIEW.

The INSTALL script prompts you to enter the directory where you want to 
install LabVIEW, which is typically /usr/local. The script also 
optionally runs the installation scripts for the NI-VISA and NI-488.2 
drivers. The INSTALL script uses rpm to install on systems that support the 
.rpm format or to extract the rpm archives directly on other systems. You 
also can install the files manually by using rpm—or a GUI rpm-based 
install tool—on Red Hat or other rpm-based systems or on systems 
without rpm by using the utilities in the bin directory on the LabVIEW 
installation CD.

If you installed Netscape or Mozilla in the default location, the LabVIEW 
installation program automatically installs the browser plug-in so you can 
view and control front panels remotely using a Web browser. Otherwise, 
you can install the browser plug-in manually by installing the LabVIEW 
Run-Time Engine and then copying /usr/local/lib/LabVIEW-8.2/
LV80NPlugin.so to the browser plug-in directory such as /usr/lib/
netscape/plugins, /opt/SUNWns/plugins, or/usr/lib/
mozilla/plugins.

Note You must install the browser plug-in for Firefox manually.

Refer to the readme.html document in /mnt/cdrom/linux for custom 
installation instructions and other information.
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Common LabVIEW Launch Errors on Linux
The following table lists common errors that might occur when you launch 
LabVIEW for Linux.

Refer to the National Instruments Web site at ni.com/support for 
information about other errors that might occur when you launch 
LabVIEW for Linux.

Installing LabVIEW Add-Ons
You can purchase several add-on software modules and toolkits for 
developing specialized applications. All the add-ons integrate seamlessly 
in LabVIEW. 

After you install LabVIEW 8.2, complete the following steps to install 
LabVIEW add-ons.

1. Restart the computer.

2. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with the installation program.

3. Insert the LabVIEW module or toolkit installation CD and follow the 
instructions that appear on the screen.

4. After installation, enable any virus detection programs you disabled.

Note LabVIEW 8.2 might not support add-ons designed for previous versions of 
LabVIEW.

Refer to the LabVIEW Help and to the National Instruments Web site at 
ni.com/toolkits for more information about National Instruments 
add-ons. Refer to the specific add-on documentation for more information 
about installation procedures.

Error Possible Cause and Solution

Xlib: connection to :0.0 

refused by server

Possible Cause—You are trying to run LabVIEW as a user 
who does not have permission to open a window on the display 
server. You typically receive these errors after you run the su 
command to temporarily become a different user, such as root 
(superuser).

Solution—Exit the su command and launch LabVIEW as the 
login user or use the xhost or xauth commands to grant 
permission to open a window on the display server.

client is not authorized 

to connect to server

internal error during 

connection authorization 

check

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=exgha8
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp04
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Activating the LabVIEW License (Windows)
LabVIEW relies on licensing activation. You have a temporary license for 
a 30-day evaluation period. If you do not activate the LabVIEW license, 
LabVIEW functions in evaluation mode, by default, for a 30-day 
evaluation period. When the evaluation period expires, you must activate a 
valid LabVIEW license to continue using LabVIEW.

To activate LabVIEW, use the serial number you received as part of your 
installation package. You can activate the LabVIEW license in any of the 
following ways:

• During installation, enter the serial number and select to run the 
NI Activation Wizard at the end of installation.

• After you launch LabVIEW in evaluation mode, click the Activate 
button in the LabVIEW dialog box.

• While running LabVIEW in evaluation mode, select Help»Activate 
LabVIEW. The license activation does not take effect until you restart 
LabVIEW.

If you do not activate LabVIEW during installation, LabVIEW prompts 
you for activation when you launch LabVIEW. After you activate the 
LabVIEW license, you no longer see this prompt. If the activation fails, 
LabVIEW remains in evaluation mode until the 30-day evaluation period 
expires.

Access to LabVIEW Is Dependent on License Activation
For all VIs or libraries that do not have a valid license specific to the version 
of LabVIEW that you purchased, you cannot perform the following tasks:

• Access or print the block diagram.

• Edit the front panel or block diagram.

• Edit polymorphic VIs.

• Run the VI.

• Run parent VIs that use the VI as a subVI.

• Save the VI to a previous version of LabVIEW or select File»
Save As.

• Complete a compare operation.

If you open a VI while LabVIEW is in evaluation mode, you cannot 
perform the following tasks:

• Access or print the block diagram.

• Edit the front panel or block diagram.
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If you run LabVIEW in evaluation mode and then purchase and activate a 
LabVIEW license for the LabVIEW Base Package, any VIs that are 
exclusive to the Full or Professional Development System versions of 
LabVIEW break. Parent VIs that use these VIs as subVIs also break. 
Similarly, if you run LabVIEW in evaluation mode and then purchase and 
activate a LabVIEW license for the LabVIEW Full Development System, 
any VIs that are exclusive to the Professional Development System version 
of LabVIEW break. Parent VIs that use these VIs as subVIs also break. 
Licensing errors appear in the Error list window.

Single-Seat and Multi-Seat Licensing
LabVIEW supports both single-seat and multi-seat licenses. Single-seat 
licensing is the use of LabVIEW on up to three computers but by only one 
user. Multi-seat, or volume, licensing is the use of LabVIEW on several 
computers or by several users. Each seat using LabVIEW must have a valid 
license from a license server. Refer to the National Instruments Web site at 
ni.com/license for more information.

Licensing for Libraries, Modules, and Toolkits
The PDA Module and the Embedded Module are licensed products, and 
you must license and activate them separately from LabVIEW. The 
Remote Panel Server, included in the LabVIEW Full and Professional 
Development Systems, also is licensed separately, but you can purchase 
additional seats.

Activating Application Builder
The LabVIEW Professional Development System includes the Application 
Builder, which activates automatically when you activate LabVIEW.

If you have an activated version of the LabVIEW Base Package or Full 
Development System, select Help»Activate Application Builder to 
activate and use the Application Builder. The license takes effect when you 
restart LabVIEW.

Installing and Configuring Hardware
After you install LabVIEW software, you can install the drivers you need 
to use National Instruments hardware. All National Instruments devices 
include the drivers and other software you need to use the device. The 
National Instruments Device Drivers CD includes the drivers and other 
software you need to use all National Instruments hardware. The drivers 
packaged with LabVIEW and those packaged with the devices might be 

http://www.ni.com/cgi-bin/redirect.cgi?dest=lmprivacy&src=lmutility
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different versions. Always use the latest available drivers that support the 
devices in your system. If you are using NI-DAQ 7.0 or later, refer to the 
NI-DAQ Readme for more information about which driver version to use 
with the devices in your system.

Note National Instruments periodically updates device drivers. Refer to the National 
Instruments Web site at ni.com/info and enter the info code exyckh to download the 
latest drivers.

(Windows) Use Measurement & Automation Explorer (MAX) or the 
Add/Remove Programs applet in the Control Panel to find the version 
number of an installed driver.

Configure National Instruments hardware after you install the drivers for 
those devices.

Windows
Use MAX to confirm that LabVIEW recognizes the device, to configure 
accessories and device settings, and to run test panels to test device 
functionality, such as the ability to acquire and generate signals. Launch 
MAX by selecting Start»All Programs»National Instruments»
Measurement & Automation or by double-clicking the Measurement & 
Automation icon on the desktop. If you are using NI-DAQ 7.4 or earlier, 
refer to the DAQ Quick Start Guide for NI-DAQ 7.x for information about 
using MAX to configure DAQ devices. If you are using NI-DAQ 7.5 or 
later, refer to the DAQ Getting Started Guide.

The way you configure virtual channels depends on whether you are using 
Traditional NI-DAQ (Legacy) or NI-DAQmx. Refer to the Getting 
Started»Getting Started with DAQ section in the LabVIEW Help for 
information about configuring channels for Traditional NI-DAQ (Legacy) 
or configuring channels or tasks for NI-DAQmx.

Mac OS 
The LabVIEW installation program installs the NI-488.2 driver for the 
GPIB interface automatically.

Linux
The LabVIEW installation program prompts you to choose the NI-488.2 
driver for the GPIB interface you are using then installs that driver 
automatically.

Note LabVIEW does not support the GPIB-1014 series (VME) devices or the original 
GPIB-SCSI box. LabVIEW does support the GPIB-SCSI-A box.

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=exyckh
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Where to Go from Here
If you are a new user, complete the exercises in the Getting Started with 
LabVIEW manual to familiarize yourself with the LabVIEW environment.

Refer to the LabVIEW Help for information about LabVIEW programming 
concepts, step-by-step instructions for using LabVIEW, and reference 
information about LabVIEW VIs, functions, palettes, menus, tools, 
properties, methods, events, dialog boxes, and so on. Access the LabVIEW 
Help by selecting Help»Search the LabVIEW Help. Refer to the Using 
Help»Searching Help book on the Contents tab of the LabVIEW Help for 
more information about using the LabVIEW Help.

The LabVIEW Help also lists the LabVIEW documentation resources 
available from National Instruments. Refer to the LabVIEW 
Documentation Resources book on the Contents tab of the LabVIEW 
Help for a list of documents.

Known Issues with LabVIEW 8.2
Refer to the readme.html file in the LabVIEW 8.2 directory for 
information about known issues with LabVIEW 8.2 and for clarifications 
and additions to the LabVIEW documentation.
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